Brown spots on leaves.

Ranja

Member
Joined
Apr 13, 2015
Messages
11
Reaction score
0
These brown spots started showing up near the tips and move inward toward the main vein of the leaf. Looks like cal issue, but I'm using full strength Cal Mag (in my RO water). I'm using DWC and my pH ranges between 5.5-6.5. Currently in week 4 of veg, and feeding 850 ppm (700 scale). Please help. Thanks.
 

Rosebud

Organic dirt farmer
Joined
Jan 2, 2010
Messages
23,146
Reaction score
6,215
Welcome Ranja, could we get a picture please?
 

zem

Well-Known Member
Joined
Dec 6, 2009
Messages
3,245
Reaction score
614
well, if you're using full strength calmag, then it most probably is not Ca. I suspect P deficiency and or PH. try to keep it between 5.5 and 6. 6.5 is high, and they become more prone to deficiency as they grow.
 

WeedHopper

Moderator
Staff member
Moderator
Bud of the Month Winner
Joined
Nov 7, 2008
Messages
16,777
Reaction score
17,890
Location
Dallas
Have you looked at the underside of the leaves?
 

Ranja

Member
Joined
Apr 13, 2015
Messages
11
Reaction score
0
Brown straight through. Didn't see any mites. Had a gnat fly issue early on, but I cleaned that up with some Azamaz.
 

Rosebud

Organic dirt farmer
Joined
Jan 2, 2010
Messages
23,146
Reaction score
6,215
As in spider mites Ranja? How long ago the azamax?
 

Ranja

Member
Joined
Apr 13, 2015
Messages
11
Reaction score
0
Yeah, spider mites. Did a root drench (0.6 strength) about three times (14 days between treatments. Just soaked the rockwool. I didn't want to load it in the reservoir - will bubble out of the res.
 

Ranja

Member
Joined
Apr 13, 2015
Messages
11
Reaction score
0
Started to really see the spots when I fed at 1000 ppm (700 scale). So I dropped it down thinking it could be lock out due to the extra nutes. Not sure.
 

Rosebud

Organic dirt farmer
Joined
Jan 2, 2010
Messages
23,146
Reaction score
6,215
I know nothing about PH, but folks will be by that do. I just wondered if that was insect damage, or if it is a result of the azamax and lights.

I think what i am seeing is a problem with the rust colored spots at the end of the leaves that i don't know what it is combined with insect damage... What does the new growth look like?

Don't worry folks that know a lot about water will be along.
 

Ranja

Member
Joined
Apr 13, 2015
Messages
11
Reaction score
0
New growth is looking good, for the most part. Starting to see some patches near some of the tips though (2nd node from the top).
 

Ranja

Member
Joined
Apr 13, 2015
Messages
11
Reaction score
0
Yeah, the rust colored spots. Never saw any bugs on the leaves, and I keep yellow bug traps all over to monitor the room....nothing. Thanks for that poster.
 

Ranja

Member
Joined
Apr 13, 2015
Messages
11
Reaction score
0
Plants seem to be doing better. Dropped the ppm down, and that seemed to do the trick. These ladies were chewing up the nutes, but 1000 ppm was too much at their size I guess.
 

MR1

Well-Known Member
Joined
Mar 31, 2014
Messages
1,255
Reaction score
33
Calcium deficiency maybe?
 

Ranja

Member
Joined
Apr 13, 2015
Messages
11
Reaction score
0
Yeah, that's what it looked like. Locked up. I thought I was a little conservative with the feeding regime based on what I have heard of God Bud's appetite. Grow and learn.
 
Top