Deficiency problem ?

ilv911

Well-Known Member
Joined
Jan 11, 2022
Messages
55
Reaction score
155
Location
greece
Hello people! Summer is coming !! 2 of my girls got a problem not sure what it is.. what you think?

Soil
advanced nutrient food
1 week ago i messed up my ph in water dropped low . Next watering was full feed on 6.5 ph cal/mag half dose
Day 25


Tds was at 780 day 18 so i mini flashed my girls with wrong ph in water.
 

Attachments

  • IMG_20220427_112853.jpg
    IMG_20220427_112853.jpg
    90.5 KB · Views: 23
  • IMG_20220427_112841.jpg
    IMG_20220427_112841.jpg
    55.5 KB · Views: 25

bigsur51

Well-Known Member
Joined
Jul 20, 2020
Messages
7,106
Reaction score
27,921
Location
On a mail train
plant looks healthy , the slight discoloration may just be a genetic pigmentation trait

to early to tell

i would keep an eye on itand continue the recommended feeding schedule

what brand of nutrients are you using?
 

ilv911

Well-Known Member
Joined
Jan 11, 2022
Messages
55
Reaction score
155
Location
greece
Big ones super lemon haze and small amnesia haze, fed them last time a full dose of 2ml/L iguana juice nirvana b52 from adv nutrient. Watered today again ph water 6.6 + cal/mag . Got some run of water and used my tds meter . 1200 isnt it too much? Girls should be burned right ? Or my thing needs calibration
 

Attachments

  • IMG_20220427_203702.jpg
    IMG_20220427_203702.jpg
    106.1 KB · Views: 9
  • IMG_20220427_203710.jpg
    IMG_20220427_203710.jpg
    103.4 KB · Views: 10

ilv911

Well-Known Member
Joined
Jan 11, 2022
Messages
55
Reaction score
155
Location
greece
plant looks healthy , the slight discoloration may just be a genetic pigmentation trait

to early to tell

i would keep an eye on itand continue the recommended feeding schedule

what brand of nutrients are you using?
Things getting worse. That thing is almost in all my plants even on small ones thats for m different seller/plant/country lol i rly dont know *** is going on ..

Gave them cal/mag too . Water always ph at 6.5/6.7
 

Attachments

  • IMG_20220428_234301.jpg
    IMG_20220428_234301.jpg
    64.6 KB · Views: 19
  • IMG_20220428_234032.jpg
    IMG_20220428_234032.jpg
    33.1 KB · Views: 20
  • IMG_20220428_233929.jpg
    IMG_20220428_233929.jpg
    46.2 KB · Views: 19
  • IMG_20220428_235215.jpg
    IMG_20220428_235215.jpg
    47 KB · Views: 14
Last edited:

ilv911

Well-Known Member
Joined
Jan 11, 2022
Messages
55
Reaction score
155
Location
greece
seems to me the pH is too high, flush with water pH'd to 6.0 for a few days and see how the plant reacts...
I believe that its ph problem too... When I bought my ph meter, calibrated it my tap water was close to 8. Few minutes ago calibrated again and it says that my tap water is on 7ph.. i think i MUST buy a new better one from hanna maybe not sure . Made some research too and what im seeing is that maybe ph problem messed sulfur. Some epsom salts tomorrow ,i read that they are completely harmless
 

ilv911

Well-Known Member
Joined
Jan 11, 2022
Messages
55
Reaction score
155
Location
greece
Got a new ph meter, flashed a lot run off ph was 7.5 fk.. 2 days later girls look great!! A little over watered but theres no water for the next 5 days i think . Thanks a lot guys all i can see now is that thing in the pic maybe stressed , topped them too . Thanks for solving that guys !! Peace
 

Attachments

  • IMG_20220501_193049.jpg
    IMG_20220501_193049.jpg
    51.7 KB · Views: 9
  • IMG_20220501_193041.jpg
    IMG_20220501_193041.jpg
    86 KB · Views: 9

ilv911

Well-Known Member
Joined
Jan 11, 2022
Messages
55
Reaction score
155
Location
greece
Hello ppl ! Back to problems . After 2 months of veging i started yday 12/12. Using advanced nutrient for food. Bottle says 2ml/l of water but i use 2ml on feed. Girls drinking about 5litres of water every 3 days. Maybe thats the problem right ? Burned my prev girls and im too afraid to feed ...
 

Attachments

  • IMG_20220530_193936.jpg
    IMG_20220530_193936.jpg
    91.3 KB · Views: 8
  • IMG_20220530_193746.jpg
    IMG_20220530_193746.jpg
    150.5 KB · Views: 8
  • IMG_20220530_193725.jpg
    IMG_20220530_193725.jpg
    94.9 KB · Views: 8
Last edited:

RosterMan

THEY CALL ME Mr. EYEBROW
Joined
Mar 23, 2022
Messages
8,358
Reaction score
30,109
Location
Excuse me Ma'am Just one more thing

ilv911

Well-Known Member
Joined
Jan 11, 2022
Messages
55
Reaction score
155
Location
greece

RosterMan

THEY CALL ME Mr. EYEBROW
Joined
Mar 23, 2022
Messages
8,358
Reaction score
30,109
Location
Excuse me Ma'am Just one more thing
Sorry my english suks.. what im trying to say is ...Feeding chart says for example 1ml/L sensi grow.i use 1 ml in one litre of water and thats it or if i use 5 litres of water in a single plant i have to use 1ml for evry litre of water so 5ml in 5 litres of water ? Did that once and i destryed my plant
try cutting that in half so 2.5ml to the 5L I never go by what the label says.
They look a little hungry are you using Cal/mag also
 

ilv911

Well-Known Member
Joined
Jan 11, 2022
Messages
55
Reaction score
155
Location
greece
try cutting that in half so 2.5ml to the 5L I never go by what the label says.
They look a little hungry are you using Cal/mag also
They look hungry ye. Same for cal mag. Feeding once a week 2 ml. My tds meter broke i have to buy a new one but i never found out how to calculate correctly tds..
 

BillyK

Well-Known Member
Joined
Mar 30, 2022
Messages
155
Reaction score
618
Location
Usa
I believe that its ph problem too... When I bought my ph meter, calibrated it my tap water was close to 8. Few minutes ago calibrated again and it says that my tap water is on 7ph.. i think i MUST buy a new better one from hanna maybe not sure . Made some research too and what im seeing is that maybe ph problem messed sulfur. Some epsom salts tomorrow ,i read that they are completely harmless
Hey now,
pH meters are only as good as the recent calibration and how they are stored. The sensor needs to be stored in a solution made for pH / ORP probe storage. You should also consider a 2 point calibration once a month as well. I used a $15.00 USD meter for years until I dropped it!
16610DEC-9B1E-4EBC-9BF1-D7CC07D3B371.jpeg


Epsom salt is MgSO₄ Magnesium Sulfate and is not harmless!! It is a great way to boot Mg though. Ca/Mg has both and is sometimes a better option.


If you nutrients say 1ml/L then 5L would get 5ml. But like @RosterMan said 2.5ml/5ml would be a good way to insure you're not burning. Keep an eye on them I think they'll get hungry!
 
Last edited:

Latest posts

Top