having trouble

Squid

Member
Joined
Sep 2, 2022
Messages
23
Reaction score
44
Location
USA
i am using dwc method. distilled water, general hydro nutes. i am getting bronze patches and tiny brown spots then leaves wither up. another site said it was because of ph fluctuations. i have ph up and down and try to keep it around 6.3 or so but it rises after feeding and fluctuates for a few days after feeding. please help.
 

boo

old goat
Bud of the Month Winner
Joined
Jul 21, 2020
Messages
4,149
Reaction score
20,180
Location
yo momma...
I don't know dwc but spots are spots, post up some pics and let's get a look at the issue...
 

Squid

Member
Joined
Sep 2, 2022
Messages
23
Reaction score
44
Location
USA
20220902_175213.jpg
 

WeedHopper

Well-Known Member
Staff member
Moderator
Joined
Nov 7, 2008
Messages
26,726
Reaction score
53,151
Location
Dallas
Have you tried 5.5 to 5.8 ph? I use to run DWC,,never used distilled water.
 

boo

old goat
Bud of the Month Winner
Joined
Jul 21, 2020
Messages
4,149
Reaction score
20,180
Location
yo momma...
it sure looks as if the pH is off or cal mag deficiency...I find it odd the new lower leaves seem happier than the newer leaves...hmmm
 

boo

old goat
Bud of the Month Winner
Joined
Jul 21, 2020
Messages
4,149
Reaction score
20,180
Location
yo momma...
sounds like a pH issue, do you check yours regularly...
I like the name squid better than kojak... ;)
 

Squid

Member
Joined
Sep 2, 2022
Messages
23
Reaction score
44
Location
USA
sounds like a pH issue, do you check yours regularly...
I like the name squid better than kojak... ;)
yes. i read that new plants in veg should be at 6.3 to 6.5 but im thinking now that may be too high. someone suggested 5.8
 

Latest posts

Top