Help with autos

Joined
Jan 11, 2022
Messages
21
Reaction score
44
Location
Rhode Island
So 2 weeks ago my girls “ lemon pie auto from fast buds “ started getting brown rust spots on the leaves, ive been feeding them cal-mag and reduced my nutrients really low, they are 7weeks old on a 10 week schedule, I’m only feeding fox farm tiger bloom 1 teaspoon and big bloom 2 teaspoons, after I feed I give plants a day to suck up the nutrients, then I water the next day, that’s when I put the cal mag, and sometimes black strap molasses but I stopped the molasses because of the brown spots. I’m not sure what’s causing it , am I over feeding?? I always use ph balanced water around 6.3-6.5 never below or over I’m not sure what I’m doing wrong for these spots to keep coming, I’ve clipped many leaves off but they keep coming back.....
1C02E331-879D-484B-95E6-DEC6BC76EC2E.jpeg
14E8F645-A4A5-4D8A-8C1D-47ADA627FB66.jpeg
29BDD310-7562-4575-930A-83AC503E7232.jpeg
92A9AFD8-DE45-4908-944B-93AAB3D453BC.jpeg
 

WeedHopper

Well-Known Member
Staff member
Moderator
Bud of the Month Winner
Joined
Nov 7, 2008
Messages
20,963
Reaction score
33,063
Location
Dallas
Since you started feeding CalMag have you noticed your new leaves having any issues? If not problem solved. I dont see a lot of turn and burn so i dont think your over feeding. They look good and healthy. Brown spots like that can be a CalMag deficiency and since you started feeding with CalMag that may have solved your problem..
 
Joined
Jan 11, 2022
Messages
21
Reaction score
44
Location
Rhode Island
Personally I don't think they will be finished in 3 weeks though.
You’d be surprised , my last grow my autos legit doubled in size within a 2 day range, I also noticed they are growing slower this time, but I did over water in the beginning which might of added 2 weeks extra , autos are so delicate, and since they run on a time line one mistake can cost you bad yield!
 
Last edited:
Joined
Jan 11, 2022
Messages
21
Reaction score
44
Location
Rhode Island
Since you started feeding CalMag have you noticed your new leaves having any issues? If not problem solved. I dont see a lot of turn and burn so i dont think your over feeding. They look good and healthy. Brown spots like that can be a CalMag deficiency and since you started feeding with CalMag that may have solved your problem..
Yes I’ve given them cal mag about 4 times already, the brown spots keep coming back still and I just keep pulling them off as they show , I did notice that the browns spots started to show after feeding molasses , but I used cal mag and molasses together and thought that would solve the first round of browns spots I saw , but the molasses is supposed to feed the soil not the plant so I’m not sure how that would burn, I only used 2 tables spoons of black strap molasses.
 

WeedHopper

Well-Known Member
Staff member
Moderator
Bud of the Month Winner
Joined
Nov 7, 2008
Messages
20,963
Reaction score
33,063
Location
Dallas
Flushing wont slow down anything. It just removes the salt build up.
Is your new leaves good?
 
Joined
Jan 11, 2022
Messages
21
Reaction score
44
Location
Rhode Island
The new leaves were showing rust spots 8 days ago but I fixed the issue, I basically did what you said and flushed , but then I fed nutrients with nitrogen for green growth to build back some of the damaged leaves and make some smaller ones grow.
 

oldfogey8

Grouch
Joined
May 12, 2014
Messages
4,983
Reaction score
9,873
Yes I’ve given them cal mag about 4 times already, the brown spots keep coming back still and I just keep pulling them off as they show , I did notice that the browns spots started to show after feeding molasses , but I used cal mag and molasses together and thought that would solve the first round of browns spots I saw , but the molasses is supposed to feed the soil not the plant so I’m not sure how that would burn, I only used 2 tables spoons of black strap molasses.
Molasses does feed the
Yes I’ve given them cal mag about 4 times already, the brown spots keep coming back still and I just keep pulling them off as they show , I did notice that the browns spots started to show after feeding molasses , but I used cal mag and molasses together and thought that would solve the first round of browns spots I saw , but the molasses is supposed to feed the soil not the plant so I’m not sure how that would burn, I only used 2 tables spoons of black strap molasses.
Molasses does feed the microbes in the soil and gives them energy to chelate nutrients thereby feeding the plants. So more nutrients available to the plant which can cause nute burn. Usually if the soil is too acidic, the uptake of CalMag is slowed. I think @SubmarineGirl has a thread where she is using pH’d water to bring up the pH of the soil to counteract a suspected CalMag deficiency.
 

Latest posts

Top